当前位置: 首页 > web开发 > PHP > 正文

PHPMYADMIN错误:require_once(./libraries/common.lib.php)解决办法

时间:2013-07-01

PHPMYADMIN Warning: require_once(./libraries/common.lib.php)错误解决办法

有的时候安装好 PHPmyAdmin后,在IE里访问时会出现下面的这种情况:

Warning: require_once(./libraries/common.lib.php): failed to open stream: No such file or directory in ***\index.php on line 40

Fatal error: main(): Failed opening required './libraries/common.lib.php' (include_path='.;c:\php5\pear') in

***\index.php on line 40

Warning: require_once(./libraries/common.inc.php) [function.require-once]: failed to open stream: No such file or directory in E:\www\index.php on line 34

Fatal error: require_once() [function.require]: Failed opening required './libraries/common.inc.php' (include_path='.;C:\php5\pear') in E:\www\index.php on line 34

出现这种问题的原因有下面几种:

1、你的PHPmyAdmin目录放到了磁盘的根目录下

2、 你的PHPmyAdmin目录及上层目录的权限设置问题

解决方法:

·将PHPmyAdmin的目录不要放在磁盘的根目录下,如放在D:\SiteManage\phpmyadmin

·将PHPmyAdmin的目录及上层目录,设置权限如下:

Users    读取和运行

IUSR_……  读 取和运行

另外的解决方法:

-----------------

遇到个奇怪的问题 。在安装完phpmyadmin后报如下错误:

Warning: require_once(./libraries/common.lib.php) [function.require-once]: failed to open stream: No such

file or directory in X:\Xxxxx\phpmyadmin\index.php on line 36

Fatal error: require_once() [function.require]: Failed opening required ‘./libraries/common.lib.php’

(include_path=’.;C:\php5\pear’) in X:\Xxxxx\phpmyadmin\index.php on line 36